Нужна консультация перелопатил много форумов со своей проблемой, но решения не нашел.
Собственно возникла необходимость в IP-ATS, в качестве платформы выбрал Elastix 2.5.0
По техническим причинам связь нам предоставляет Энфорта.
От них нам приходит 3-и тел. номера, реализовано это на 2-х адпаках:
На первый адпак с IP 172.XX.XXX.149 и одним портом FXS заведен один гор. номер
На второй адпак с IP 172.XX.XXX.163 и двумя портами FXS заходят еще два гор. номера.
Эти номера мне нужно завести в Elastix через OOH323
в дистрибутиве он присутствует
Код: Выделить всё
Type Description Devicestate Indications Transfer
----------- ----------- ----------- ----------- -----------
USTM UNISTIM Channel Driver no yes no
Phone Standard Linux Telephony API Driver no yes no
EXTRA GSM/CDMA Telephony Driver FOR Asterisk w no yes no
OOH323 Objective Systems H323 Channel Driver no yes no
ConfBridgeRec Conference Bridge Recording Channel no no no
MulticastRTP Multicast RTP Paging Channel Driver no no no
SIP Session Initiation Protocol (SIP) yes yes yes
IAX2 Inter Asterisk eXchange Driver (Ver 2) yes yes yes
Jingle Jingle Channel Driver no yes no
Gtalk Gtalk Channel Driver no yes no
DAHDI DAHDI Telephony Driver w/PRI & SS7 & MFC yes yes no
Bridge Bridge Interaction Channel no no no
Agent Call Agent Proxy Channel yes yes no
MGCP Media Gateway Control Protocol (MGCP) yes yes no
Local Local Proxy Channel Driver yes yes no
У добрых людей раздобыл свой конфиг одного из AddPac, это максимум что они могут сделать, человек который мог бы мне помочь уволился и уехал из области.
Код: Выделить всё
interface Loopback0
ip address 127.0.0.1 255.0.0.0
!
interface FastEthernet0/0
ip address 172.XX.XXX.163 255.255.255.0
encapsulation dot1Q 103
ip nat outside
speed auto
no qos-control
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
ip nat inside
speed auto
no qos-control
!
ip route 0.0.0.0 0.0.0.0 172.XX.XXX.1 10
!
access-list 100 permit ip 192.168.10.0 0.0.0.255 any
!
!
ip nat inside source list 100 interface FastEthernet0/0 overload
!
ip tos rtp precedence 5
ip tos rtp delay
ip tos rtp throughput
ip tos signaling precedence 5
ip tos signaling delay
ip tos signaling throughput
! VoIP configuration.
! Voice service voip configuration.
!
voice service voip
fax protocol t38 redundancy 0
fax rate 9600
h323 call start fast
h323 call channel early
h323 call tunnel enable
timeout tring 180
timeout tidt 5
timeout tttl 300
local-ringback-tone alert
max-frame g729 6
max-frame g711 3
busyout monitor gatekeeper
busyout monitor sip-server
no busyout monitor callagent
busyout monitor voip-interface
display send none
dynamic-payload-type nte-rfc2833 127
!
! Voice port configuration.
!
! FXS
voice-port 0/0
no comfort-noise
fax-early-detect
caller-id enable
caller-id name disable
!
! FXS
voice-port 0/1
no comfort-noise
fax-early-detect
caller-id enable
caller-id name disable
!
! Pots peer configuration.
!
dial-peer voice 1000 pots
destination-pattern 90078CCCXXX131
port 0/0
!
dial-peer voice 1010 pots
destination-pattern 90078CCCXXX132
port 0/1
!
! Voip peer configuration.
!
dial-peer voice 9900 voip
destination-pattern T
session target ras
answer-address T
voice-class codec 3
no vad
codec-variant g729 annex-a
dtmf-relay dual-mode
!
! Gateway configuration.
!
gateway
h323-id voip.172.XX.XXX.163
security password 123450
security clear-token-option cisco-endpoint-style
gkip 172.XX.XXX.6 1719 1
gkip 172.XX.XXX.5 1719 2
keep-gk-on-rrj
ignore-msg-from-other-gk
register
!
! Codec classes configuration.
!
voice class codec 1
codec preference 1 g729
codec preference 2 g711alaw
!
voice class codec 2
codec preference 1 g711alaw
codec preference 2 g729
!
voice class codec 3
codec preference 1 g729
!
voice class codec 4
codec preference 1 g711alaw
!
! SIP UA configuration.
!
sip-ua
!
! MGCP configuration.
!
mgcp
codec g711ulaw
vad
!
!
! Tones
voice class dial-tone 425 0 0 0 0 0 -12
!
voice class ring-back-tone 425 0 1000 4000 0 0 -12
!
voice class line-busy-tone 425 0 350 350 0 0 -12
!
voice class reorder-tone 425 0 349 350 0 0 -12
!
!
line console
!
line vty
!
sms
quota 30
!
end
1 Создаю специальный транк с названием Enforta
Caller ID - "hidden"
Разрешаю любые CID
Спец набор OOH323/$OUTNUMS$@enforta
2 Создаю/редактирую файл ooh323.conf
3 Перезагружаюсь
Код: Выделить всё
[general]
port=1720
tracelevel=7
bindaddr=172.XX.XXX.149
h323id=voip.172.XX.XXX.149
secret=123450
gateway=no
gatekeeper = DISABLE
faststart=yes
h245tunneling=yes
;mediawaitforconnect=no
logfile=/var/log/asterisk/h323_log
context=from-enforta
rtptimeout=60
disallow=all
allow=alaw:30
allow=gsm
allow=ulaw
dtmfmode=rfc2833
dtmfcodec=127
tunneling=cisco
progress_setup=8
progress_alert=8
[enforta]
type=friend
ip=172.XX.XXX.6
port=1720
context=from-enforta
rtptimeout=60
disallow=all
allow=alaw:30
allow=gsm
allow=ulaw
dtmfmode=rfc2833
canreinvite=yes
t38pt_udptl = yes,fec,maxdatagram=400
t38pt_rtp=no
t38pt_tcp=no
Код: Выделить всё
[from-enforta]
exten => _.,1,Set(CALLERID(all)=8${CALLERID(num):-10:10})
exten => _.,2,Set(CALLERID(ANI-all)=${CALLERID(num)})
exten => _.,3,Goto(from-trunk,${EXTEN},1)
Код: Выделить всё
---------Date 27---------
18:56:18:268 Signalling IP address is set to 172.XX.XXX.149
18:56:18:268 Listen port number is set to 1720
18:56:18:268 TCP port range initialize - successful
18:56:18:268 Added alias: H323ID - voip.172.XX.XXX.149
18:56:18:268 Adding endpoint capability OO_G711ALAW64K.
18:56:18:268 Adding endpoint capability OO_G711ULAW64K.
18:56:18:268 Enabled RFC2833 DTMF capability for end-point
18:56:18:268 H323 listener creation - successful
18:56:18:269 H.323 Endpoint Configuration is as follows:
18:56:18:269 Trace File: /var/log/asterisk/h323_log
18:56:18:269 FastStart - enabled
18:56:18:269 H245 Tunneling - enabled
18:56:18:269 MediaWaitForConnect - disabled
18:56:18:269 AutoAnswer - disabled
18:56:18:269 Terminal Type - 60
18:56:18:269 T35 CountryCode - 184
18:56:18:269 T35 Extension - 0
18:56:18:269 Manufacturer Code - 39
18:56:18:270 ProductID - ooh323
18:56:18:270 VersionID - v0.8.3m
18:56:18:270 Local signalling IP address - 172.XX.XXX.149
18:56:18:270 H225 ListenPort - 1720
18:56:18:270 CallerID - voip.172.XX.XXX.149
18:56:18:270 Call Establishment Timeout - 60 seconds
18:56:18:270 MasterSlaveDetermination Timeout - 30 seconds
18:56:18:270 TerminalCapabilityExchange Timeout - 30 seconds
18:56:18:270 LogicalChannel Timeout - 30 seconds
18:56:18:270 Session Timeout - 15 seconds
18:58:24:236 Processing MakeCall command ooh323c_o_1
18:58:24:236 Created a new call (outgoing, ooh323c_o_1)
18:58:24:236 Added remote alias OUTNUMS to call. (outgoing, ooh323c_o_1)
18:58:24:236 Enabled RTP/CISCO DTMF capability for (outgoing, ooh323c_o_1)
18:58:24:236 Enabled RFC2833 DTMF capability for (outgoing, ooh323c_o_1)
18:58:24:236 Dtmf mode set to H.245(alphanumeric) for (outgoing, ooh323c_o_1)
18:58:24:236 Dtmf mode set to H.245(signal) for (outgoing, ooh323c_o_1)
18:58:24:236 Adding call specific capability OO_T38. (outgoing, ooh323c_o_1)
18:58:24:236 Adding call specific capability OO_G711ALAW64K. (outgoing, ooh323c_o_1)
18:58:24:236 Adding call specific capability OO_GSMFULLRATE. (outgoing, ooh323c_o_1)
18:58:24:236 Adding call specific capability OO_G711ULAW64K. (outgoing, ooh323c_o_1)
18:58:24:237 Configured mediainfo for cap OO_G711ALAW64K (outgoing, ooh323c_o_1)
18:58:24:237 Configured mediainfo for cap OO_G711ALAW64K (outgoing, ooh323c_o_1)
18:58:24:237 Configured mediainfo for cap OO_GSMFULLRATE (outgoing, ooh323c_o_1)
18:58:24:237 Configured mediainfo for cap OO_GSMFULLRATE (outgoing, ooh323c_o_1)
18:58:24:237 Configured mediainfo for cap OO_G711ULAW64K (outgoing, ooh323c_o_1)
18:58:24:237 Configured mediainfo for cap OO_G711ULAW64K (outgoing, ooh323c_o_1)
18:58:24:237 Configured mediainfo for cap OO_T38 (outgoing, ooh323c_o_1)
18:58:24:237 Configured mediainfo for cap OO_T38 (outgoing, ooh323c_o_1)
18:58:24:237 INFO: FinCall returned 17536008 for call: ooh323c_o_1
18:58:24:237 INFO: FinCall returned 17536008 for call: ooh323c_o_1
18:58:24:237 INFO: create cmd connect for call: 17536008
18:58:24:247 Processing MakeCall command ooh323c_o_1
18:58:24:247 INFO: FinCall returned 17536008 for call: ooh323c_o_1
18:58:24:247 Parsing destination 172.XX.XXX.6:1720
18:58:24:247 Generated callRef 11
18:58:24:247 Trying to connect to remote endpoint(172.XX.XXX.6:1720) (IPv4) to setup H2250 channel (outgoing, ooh323c_o_1)
18:58:30:196 INFO: FinCall returned 17536008 for call: ooh323c_o_1
19:01:32:750 ERROR:Failed to connect to remote destination for transmit H2250 channel(outgoing, ooh323c_o_1, 39, 172.XX.XXX.149)
19:01:32:750 Trying to connect to remote endpoint(172.XX.XXX.6:1720) (IPv4) to setup H2250 channel (outgoing, ooh323c_o_1)
19:07:50:750 In ooEndCall call state is - OO_CALL_CLEAR (outgoing, ooh323c_o_1)
19:07:50:750 Cleaning Call (outgoing, ooh323c_o_1)- reason:OO_REASON_NOUSER
19:07:50:750 Closing H.245 connection (outgoing, ooh323c_o_1)
19:07:50:750 Removing call 17536008: ooh323c_o_1
19:07:50:750 Removed call (outgoing, ooh323c_o_1) from list
19:07:50:750 Ending Call Monitor thread